aerobase-ctl commands failed on windows server when fips mode is enabled

Description

Enable fips mode

  • Log on to Windows as a Windows system administrator.

  • Click Start.

  • Click Control Panel.

  • Click Administrative Tools. ...

  • Click Local Security Policy. ...

  • In the navigation pane, click Local Policies, and then click Security Options.

run reconfigure

`aerobase-ctl.bat reconfigure`

Error:

1 2 3 4 5 6 7 8 9 10 11 Traceback (most recent call last): 9: from C:/PROGRA~2/Aerobase/Aerobase/embedded/bin/chef-client:23:in `<main>' 8: from C:/PROGRA~2/Aerobase/Aerobase/embedded/bin/chef-client:23:in `load' 7: from C:/Program Files (x86)/Aerobase/Aerobase/embedded/lib/ruby/gems/2.5.0/gems/chef-14.8.12-universal-mingw32/bin/chef-client:25:in `<top (required)>' 6: from C:/Program Files (x86)/Aerobase/Aerobase/embedded/lib/ruby/gems/2.5.0/gems/chef-14.8.12-universal-mingw32/lib/chef/application.rb:64:in `run' 5: from C:/Program Files (x86)/Aerobase/Aerobase/embedded/lib/ruby/gems/2.5.0/gems/chef-14.8.12-universal-mingw32/lib/chef/application/client.rb:313:in `reconfigure' 4: from C:/Program Files (x86)/Aerobase/Aerobase/embedded/lib/ruby/gems/2.5.0/gems/chef-14.8.12-universal-mingw32/lib/chef/application.rb:55:in `reconfigure' 3: from C:/Program Files (x86)/Aerobase/Aerobase/embedded/lib/ruby/gems/2.5.0/gems/chef-14.8.12-universal-mingw32/lib/chef/application.rb:99:in `configure_chef' 2: from C:/Program Files (x86)/Aerobase/Aerobase/embedded/lib/ruby/gems/2.5.0/gems/chef-config-14.8.12/lib/chef-config/config.rb:587:in `init_openssl' 1: from C:/Program Files (x86)/Aerobase/Aerobase/embedded/lib/ruby/gems/2.5.0/gems/chef-config-14.8.12/lib/chef-config/config.rb:1132:in `enable_fips_mode' C:/Program Files (x86)/Aerobase/Aerobase/embedded/lib/ruby/gems/2.5.0/gems/chef-config-14.8.12/lib/chef-config/config.rb:1132:in `fips_mode=': This version of OpenSSL does not support FIPS mode (OpenSSL::OpenSSLError)

Environment

None

Status

Assignee

Yaniv Marom Nachumi

Reporter

Yaniv Marom Nachumi

Labels

None

Fix versions

Affects versions

v2.3.3
v2.3.4

Priority

Medium